Important notice for Microsoft Windows XP and Windows Vista users

October 2017

Future versions of NBS Create, NBS Building, NBS Contract Administrator, NBS Landscape and NBS Scheduler will not be compatible with Microsoft Windows XP and Windows Vista.

More Information

We update these programs to make them better for all user and to ensure everyone is using the latest technology and security. In doing so, newer versions will not be compatible with these older Windows operating systems.

Microsoft have not supported these operating systems since 2012 and 2014. 

If you run these Windows operating systems, we advise you to upgrade your PC to benefit from the latest releases. For the latest compatibility information, please see the system requirements page for your chosen program:

If you have any questions or queries please contact the NBS Software Support Team.