Summary

You can configure your NBS software to suit your preferences by manually adjusting the file locations. You won't be able to copy and paste or type in the paths, only browse to the locations.

Please Note: settings only take effect on the machine they’re changed on and only when you restart the software.

More information

Select Tools > My Settings > File location tab - here you can edit file and folder paths related to your NBS software. Below is a list of locations you can change (Please Note: paths that have a padlock next to them require the user to be logged in as an administrator within the software):

file_location_01

  • Default Specification Location: The location where your Specification files will be created automatically unless changed.
  • Default Preliminaries Location: The location where your Preliminaries files will be created automatically unless changed.
  • NBS Libraries Location: The location in where all the NBS data (which contain the NBS Guidance and Clause information) is stored and saved here. Note: If you are running a network install it is advised to keep this location pointing to the network.
  • Office Standards Location: The location where your office standards will be created automatically unless changed. This also sets the location for browsing to office standards in the references section.
  • Default “Save As” Location: The automatically selected save location from File > Save As in the menu. This location can be changed when saving the file.
  • Office Print Settings Location: This file stores print settings for printing from the NBS software. You can point all machines to this file and the printouts will use the same font size, colour, style etc.
  • Compact Recovery Location: The location where the software will look first for a specification or preliminary file when using the Compact Specification tool. The tool can be found in the menu under Tools > Compact Specification...
  • Security File Location: Location for the file called ‘security.sms’ – this file contains user accounts for logging into the software. If you want all your machines to have the same user login details, they will need to point to the same security.sms file on the network.
  • Office Settings File Location: Stores the file locations for all of the above in a file called ‘officesettings.xml’. If a machine points to this Office Settings file, the paths above will change to reflect what is set in this file. (Please Note: file paths will have a padlock next to them to indicate that they can only be adjusted within the officesettings.xml file).

Related articles

Default login credentials

Editing the Office Settings file